Sq Four MkI and Thorspark Ignition

General electrical problems
Gui.dorey
Holder of a Nylon Anorak
Holder of a Nylon Anorak
Posts: 114
Joined: Tue Sep 05, 2017 7:42 pm
Contact:

Sq Four MkI and Thorspark Ignition

Postby Gui.dorey » Mon Sep 16, 2019 8:08 am

Hello Everyone,

I installed a Thorspark Ignition on my Sq 4 and was very happy with it. Easy starting, ran great. A few days ago the engine just died while in top gear, all lights out, all electrics dead. Fortunately I was just about to turn into the street where I live so I didn’t have to push her very long.

Anyway, the fault was traced first to a blown main fuse, and later to a short inside the pickup sensor of the Thorspark. Even with the base plate out of the distributor, and all other electrics isolated, the main fuse still blows as soon as the ign is turned on, i.e. as soon as the sensor gets power.

What are your experiences with Thorspark? Any similar problems?

I’m running 12V electrics and negative earth.

Cheers,
Gui
Attachments
34A4AFB2-BA20-47B9-91D2-36E83E93154F.jpeg
0057A310-4A46-4AFA-B01E-8D04F82CC3A0.jpeg

User avatar
Brian_Walker
Posts: 76
Joined: Mon Mar 19, 2018 9:40 am
Location: Sydney, Australia
Contact:

Re: Sq Four MkI and Thorspark Ignition

Postby Brian_Walker » Fri Nov 29, 2019 12:20 am

Check the coil, insulation might be crook and causing short. See if it blows fuse with the coil disconnected.
1951-52 VCH under restoration


Return to “Electrics”

Who is online

Users browsing this forum: No registered users and 1 guest