Charging problem?

General electrical problems
Brian.Challinor
Holder of a Nylon Anorak
Holder of a Nylon Anorak
Posts: 122
Joined: Thu Dec 01, 2011 10:28 pm
Location: Crewe
Contact:

Charging problem?

Postby Brian.Challinor » Thu Dec 03, 2020 10:44 am

Hello, The problem I have is on start up the dynamo (c35sd) on my 51 sq4 doesn't seem do do anything until after about a minute of running it comes to life, I have to rev the engine and sometimes switch the lights on and off to get a + reading on the ammeter. I overhauled the dynamo during the rebuild. I have a new battery fitted and use a DVR2 regulator. After the dynamo kicks in it charges ok, but I have to go through the same sequence on initial start up. I'm thinking the field coils are weak.

JohnnyBeckett
Holder of a Golden Anorak
Holder of a Golden Anorak
Posts: 1405
Joined: Sat Jul 07, 2018 5:39 pm
Contact:

Re: Charging problem?

Postby JohnnyBeckett » Thu Dec 03, 2020 2:20 pm

hi have you made sure the dynamo has got a good earth and all the earths on the bike and the regulator can some times be a bit lazy to start up :?:

Brian.Challinor
Holder of a Nylon Anorak
Holder of a Nylon Anorak
Posts: 122
Joined: Thu Dec 01, 2011 10:28 pm
Location: Crewe
Contact:

Re: Charging problem?

Postby Brian.Challinor » Thu Dec 03, 2020 6:52 pm

Thanks for reply, I will check earths but I think they are good.

JohnnyBeckett
Holder of a Golden Anorak
Holder of a Golden Anorak
Posts: 1405
Joined: Sat Jul 07, 2018 5:39 pm
Contact:

Re: Charging problem?

Postby JohnnyBeckett » Thu Dec 03, 2020 9:39 pm

hi Brian have you check the volts at the battery with the engine running, my 6v is showing 7.2 volts with the engine running but no Amps till i rev it or ride it then it shows it charging i put it down to the new type of regulators
Last edited by JohnnyBeckett on Fri Dec 04, 2020 5:38 pm, edited 2 times in total.

Brian.Challinor
Holder of a Nylon Anorak
Holder of a Nylon Anorak
Posts: 122
Joined: Thu Dec 01, 2011 10:28 pm
Location: Crewe
Contact:

Re: Charging problem?

Postby Brian.Challinor » Thu Dec 03, 2020 10:30 pm

Will check tomorrow, the bike runs a bit rough until it starts charging, then its fine.

User avatar
admin
Holder of a Golden Anorak
Holder of a Golden Anorak
Posts: 1032
Joined: Thu Feb 10, 2011 1:22 pm
Location: Herefordshire, UK
Contact:

Re: Charging problem?

Postby admin » Fri Dec 04, 2020 11:46 am

My magdyno dynamos do this.
The electronic regulators, fitted inside the original reg boxes, seem to want a bit of current (generated by revving ) to wake up.
John Nash
Administrator
webmaster@arielownersmcc.co.uk

Brian.Challinor
Holder of a Nylon Anorak
Holder of a Nylon Anorak
Posts: 122
Joined: Thu Dec 01, 2011 10:28 pm
Location: Crewe
Contact:

Re: Charging problem?

Postby Brian.Challinor » Fri Dec 04, 2020 12:00 pm

The reason I posted was because I don't like revving the engine from cold. Its made feel a bit better knowing that its a ''problem'' with the regulator and not the dynamo probably.

User avatar
chris.shearwood
Holder of a Waxed Cotton Anorak
Holder of a Waxed Cotton Anorak
Posts: 521
Joined: Mon Feb 28, 2011 5:28 pm
Location: Sutton, Quebec, Canada
Contact:

Re: Charging problem?

Postby chris.shearwood » Fri Dec 04, 2020 12:31 pm

You can run a wire from the Dynamo wire to the Field wire with a momentary switch in the circuit. Touching the switch should be enough to wake up the regulator. A bit of a bodge but what the H***
1946 4G, 1950 NG and 1951 VH

will_curry
Holder of a Waxed Cotton Anorak
Holder of a Waxed Cotton Anorak
Posts: 349
Joined: Thu Oct 08, 2015 12:56 am
Contact:

Re: Charging problem?

Postby will_curry » Fri Dec 04, 2020 6:02 pm

The problem is a function of the internal resistance of the electronic
regulator. Chris's fix works by by-passing the regulator momentarily.

Brian.Challinor
Holder of a Nylon Anorak
Holder of a Nylon Anorak
Posts: 122
Joined: Thu Dec 01, 2011 10:28 pm
Location: Crewe
Contact:

Re: Charging problem?

Postby Brian.Challinor » Sat Dec 05, 2020 12:58 pm

Heres what the makers hd to say
Capture33.PNG
Attachments
Capture34.PNG
Capture34.PNG (7.2 KiB) Viewed 441 times
Capture32.PNG


Return to “Electrics”

Who is online

Users browsing this forum: No registered users and 2 guests